MSGUNTYPOT.1P(1) User Contributed Perl Documentation MSGUNTYPOT.1P(1)

msguntypot - Mettre à jour des fichiers PO quand une typo est corrigée dans un fichier POT

msguntypot -o ancien_pot -n nouveau_pot fichier_po ...

Lorsque vous corrigez une erreur triviale qui n’affectera pas les traductions (par exemple une faute d’orthographe) dans un fichier POT, vous devriez retirer l’étiquette fuzzy sur les msgstr correspondantes dans les fichier PO afin d’éviter du travail supplémentaire aux équipes de traduction.

Cette tâche est difficile et peut générer des erreurs quand elle est faite manuellement. Cet outil est là pour vous aider à faire ceci correctement. Vous n’avez qu’à fournir les deux versions du fichier POT : avant la correction et après, comme indiqué dans la synopsis ci-dessus. Tout le reste est fait automatiquement.

En bref, quand vous découvrez une erreur dans un de vos messages (en anglais), faites comme suit :

make -C po/ update-po # pour les traductions des messages d’un programme
debconf-updatepo      # pour les traductions debconf
po4a po4a.conf        # pour les traductions de documentation utilisant po4a

ou quelque chose d’autre en fonction de votre projet. Vous savez comment mettre à jour vos fichiers POT et PO, n’est-ce pas ?

cp monfichier.pot monfichier.pot.orig
mkdir po_orig; cp *.po po_orig
$EDITOR le_fichier_à_corriger
Voir ci-dessus.

À ce moment là, la correction a marqué certaines chaines fuzzy, et ce changement malheureusement est la seule modification entre les fichiers PO de votre répertoire et ceux de po_orig. Voici comment corriger cela.

cp po_orig/*.po .
msguntypot -o monfichier.pot.orig -n monfichier.pot *.po
rm -rf monfichier.pot.orig po_orig

C’est fini. L’erreur a été supprimée des messages de vos fichiers POT et PO, et les fichiers PO n’ont pas été fuzzyfiés au passage. Maintenant, vos équipes de traduction vous aiment.

Contrairement à ce que son nom indique, cet outil ne fait pas partie de la suite d’outils gettext. Il fait partie de po4a. Plus précisément, il s’agit d’un script Perl utilisant les modules de po4a. Pour en savoir plus sur po4a, consultez :

po4a(7)

Martin Quinson (mquinson#debian.org)

Martin Quinson (mquinson#debian.org)

Copyright 2005 par SPI, inc.

Ce programme est un logiciel libre ; vous pouvez le copier et / ou le modifier sous les termes de la GPL v2.0 ou suivante (voir le fichier COPYING).

2024-06-08 perl v5.38.2