LOCALE::PO4A::COMMON.3PM(1) User Contributed Perl Documentation LOCALE::PO4A::COMMON.3PM(1)

Locale::Po4a::Common - allgemeine Teile von Po4a-Skripten und -Werkzeugen

Locale::Po4a::Common enthält allgemeine Teile der Po4a-Skripte und einige nützliche Funktionen, die von den anderen Modulen verwandt werden.

Falls notwendig können Sie Text::WrapI18N deaktiveren, indem Sie

use Locale::Po4a::Common qw(nowrapi18n);
use Locale::Po4a::Text;

anstelle Folgendem schreiben:

use Locale::Po4a::Text;

Die Reihenfolge ist hier wichtig: da die meisten Locale::Po4a-Module selbst Locale::Po4a::Common laden, wird beim ersten Laden des Moduls entschieden, ob Text::WrapI18N verwandt wird.

  • show_version($)

    Zeigt die aktuelle Version des Skriptes und eine kurze Copyright-Nachricht an. Es erwartet den Namen des Skriptes als Argument.

  • wrap_msg($@)

    Diese Funktion zeigt eine Nachricht genauso an, wie das sprintf() macht, fügt aber einen Zeilenumbruch hinzu, so dass sie auf einem Terminal gut aussieht.

  • wrap_mod($$@)

    Diese Funktion funktioniert wie wrap_msg(), erwartet aber den Modulnamen als erstes Argument und lässt links der Nachricht noch ein Leerzeichen.

  • wrap_ref_mod($$$@)

    Diese Funktion funktioniert wie wrap_msg(), erwartet aber eine file:line-Referenz als erstes Argument, einen Modulnamen als zweites und lässt links der Nachricht noch ein Leerzeichen.

Locale::Gettext

Wenn das Modul Locale::Gettext nicht geladen werden kann, stellt dieses Modul eine Pseudo- (leere) Implementierung der im Folgenden aufgeführten Funktionen dar. In diesem Fall werden die Nachrichten nicht durch Po4a übersetzt, aber das Programm wird weiterhin funktionieren.

Falls Locale::gettext vorhanden ist, ruft dieser Adapter auch setlocale(LC_MESSAGES, "") auf, so dass Aufrufende nicht auch vom POSIX-Modul abhängen müssen.

  • bindtextdomain($$)
  • textdomain($)
  • gettext($)
  • dgettext($$)

Jordi Vilalta <jvprat@gmail.com>

Copyright © 2005 SPI, Inc.

Dieses Programm ist freie Software; Sie können es unter den Bedingungen der GPL v2.0 oder neuer (siehe die Datei COPYING) vertreiben und/oder verändern.

2024-06-08 perl v5.38.2