MSGUNTYPOT.1P(1) User Contributed Perl Documentation MSGUNTYPOT.1P(1)

msguntypot - Actualiza ficheros PO cuando se corrige un error tipográfico en el fichero POT

msguntypot -o POT_antiguo -n POT_nuevoE ficheros_PO ...

Cuando arregla un error trivial que con seguridad no afecta a las traducciones (por ejemplo, un error tipográfico) en un fichero POT, debería quitar la condición de cadena difusa («unfuzzy») al correspondiente msgstr en los ficheros PO para así evitar trabajo adicional a los traductores.

Esta tarea es difícil y proclive a fallos si se hace manualmente, y esta herramienta existe para ayudarle a que lo haga correctamente. Sólo necesita proporcionar las dos versiones del fichero POT: antes de la edición y después, como se refleja en el anterior resumen, y el proceso pasará a ser automático.

Resumiendo, cuando descubre un error tipográfico en uno de sus mensajes (en inglés), haga lo siguiente:

make -C po/ update-po # para traducciones de mensajes del programa
debconf-updatepo      # para traducciones de debconf
po4a po4a.conf        # para traducciones de documentación basadas en po4a

u otra cosa, dependiendo de la configuración de los ajustes de compilación de su proyecto. Ya sabe como asegurarse de que sus ficheros PO y POT están al día, ¿no?

cp mi_fichero.pot mi_fichero.pot.orig
mkdir po_baúl; cp *.po po_baúl
$EDITOR el_fichero_en_el_que_hay_un_error
Véase arriba.

En este punto, el error corregido ha convertido en difusas traducciones presentes en todos los ficheros PO, y este desafortunado cambio es el único entre los ficheros PO de su directorio principal y aquellos en el baúl. Aquí tiene la solución.

cp po_baúl/*.po .
msguntypot -o mi_fichero.pot.orig -n mi_fichero.pot *.po
rm -rf mi_fichero.pot.orig po_baúl

Y ya está. El error se eliminó de los msgstr de los ficheros POT y PO, y los ficheros PO no añadieron cadenas difusas en el proceso. Sus traductores ya le aman.

A pesar de su nombre, esta herramienta no forma parte del conjunto de herramientas de gettext. En lugar de ello, forma parte de po4a. Más exactamente, es un script aleatorio de Perl que usa los módulos de po4a. Para más información acerca de po4a consulte:

po4a(7)

Martin Quinson (mquinson#debian,org)

Jordi Vilalta <jvprat@gmail.com>
Omar Campagne <ocampagne@gmail.com>

Copyright 2005 por SPI, inc.

Este programa es software libre; puede redistribuirlo y/o modificarlo bajo los términos de la GPL v2.0 o posterior (consulte el archivo COPYING).

2024-06-08 perl v5.38.2