LOCALE::PO4A::COMMON.3PM(1) User Contributed Perl Documentation LOCALE::PO4A::COMMON.3PM(1)

Locale::Po4a::Common - Partes comunes de los scripts de po4a y herramientas

Locale::Po4a::Common contiene partes comunes a los scripts de po4a y algunas funciones útiles usadas por los otros módulos.

Si es necesario, puede deshabilitar el uso de Text::WrapI18N tal como:

use Locale::Po4a::Common qw(nowrapi18n);
use Locale::Po4a::Text;

en lugar de:

use Locale::Po4a::Text;

La ordenación es importante aquí: ya que la mayoría de los módulos Locale::Po4a se cargan ellos mismos Locale::Po4a::Common, la primera vez que se carga el módulo determina si se usa Text::WrapI18N.

  • show_version($)

    Muestra la versión actual del script, y un breve mensaje de derechos de autor. Toma el nombre del script como argumento.

  • wrap_msg($@)

    Esta función muestra un mensaje de la misma manera que lo hace sprintf(), pero justifica el resultado para que se vea bien en la terminal.

  • wrap_mod($$@)

    Esta función funciona como wrap_msg(), pero toma un nombre de módulo como primer argumento, y deja un espacio a la izquierda del mensaje.

  • wrap_ref_mod($$$@)

    Esta función funciona como wrap_msg(), pero toma una referencia fichero:línea como primer argumento, un nombre de módulo como segundo, y deja un espacio a la izquierda del mensaje.

Locale::Gettext

Este módulo proporciona una integración vacía («dummy») de las siguientes funciones en caso de que no se pueda cargar el módulo Locale::Gettext. De ser así, los mensajes de po4a no se traducirán pero el programa seguirá funcionando.

Si Locale::gettext está presente, este «wrapper» también invoca setlocale (LC_MESSAGES, ""), para que aquello que lo invoca tampoco dependa del módulo de POSIX.

  • bindtextdomain($$)
  • textdomain($)
  • gettext($)
  • dgettext($$)

Jordi Vilalta <jvprat@gmail.com>

Jordi Vilalta <jvprat@gmail.com>
Omar Campagne <ocampagne@gmail.com>

Copyright © 2005 SPI, Inc.

Este programa es software libre; puede redistribuirlo y/o modificarlo bajo los términos de la GPL v2.0 o posterior (consulte el archivo COPYING).

2024-02-07 perl v5.38.1