|NTPD(8)||System Manager's Manual||NTPD(8)|
ntpddaemon synchronizes the local clock to one or more remote NTP servers or local timedelta sensors.
ntpdcan also act as an NTP server itself, redistributing the local time. It implements the Simple Network Time Protocol version 4, as described in RFC 5905, and the Network Time Protocol version 3, as described in RFC 1305. Time can also be fetched from TLS HTTPS servers to reduce the impact of unauthenticated NTP man-in-the-middle attacks.
The options are as follows:
- Do not daemonize. If this option is specified,
ntpdwill run in the foreground and log to stderr.
- Use file as the configuration file, instead of the default /etc/ntpd.conf.
- Configtest mode. Only check the configuration file for validity.
ntpdwill stay in the foreground for up to 15 seconds waiting for one of the configured NTP servers to reply.
- This option allows
ntpdto send DEBUG priority messages to syslog.
- Write pid to file
ntpd uses the
adjtime(2) system call to correct
the local system time without causing time jumps. Adjustments of 32ms and
greater are logged using
syslog(3). The threshold value is
chosen to avoid having local clock drift thrash the log files. Should
ntpd be started with the
-v option, all calls to
adjtime(2) will be logged.
ntpd makes efforts to verify and correct
the time at boot if constraints are configured and satisfied or if trusted
servers or sensors return results, and if the clock is not being moved
After the local clock is synchronized,
ntpd adjusts the clock frequency using the
adjfreq(2) system call to
compensate for systematic drift.
ntpd starts up, it reads settings
from its configuration file, typically
ntpd.conf(5), and its initial
clock drift from /var/db/ntpd.drift. Clock drift is
periodically written to the drift file thereafter.
- Default configuration file.
- Drift file.
- Socket file for communication with ntpctl(8).
David L. Mills, Jim Martin, Jack Burbank, and William Kasch, Network Time Protocol Version 4: Protocol and Algorithms Specification, RFC 5905, June 2010.
ntpdprogram first appeared in OpenBSD 3.6.
|November 11, 2019||Linux 5.10.9-arch1-1|