|MOUNT_AFP(8)||System Manager's Manual||MOUNT_AFP(8)|
mount_afpcommand mounts the AFP volume denoted by the afp_url afp://[user[;AUTH=uamname][:password]@]host[:port]/volumename at the mount point indicated by node.
This is normally a symlink to the afp_client(1) executable, which is a full implementation to mount AFP volumes using the FUSE infrastructure. It communicates with afpfsd, a daemon that manages AFP sessions. The arguments and options are:
- Options passed to mount(2) are
specified with the
-ooption followed by a comma separated string of options. man page for possible options and their meanings. Additional options supported by the AFP Client are as follows:
- The only available option is "-o volpassword=XXX" to set the volume password (since there is no facility for that in an AFP URL).
- Mount the volume as writeable. This is the default, so it has no effect.
- Mount the volume as readonly.
- Mount the volume as groupname.
- Mount the volume as username.
- There are two forms of afp URL, one for TCP/IP and one for AppleTalk:
Denotes the afp server and sharepoint to mount. It may also contain the username & password required to log into the server. uamname is the protocol name of the authentication method. If port is not specified, then port 548 is used.
- Path to mount point, which must be a directory that the user has write permissions for.
mkdir /Volumes/mntpnt mount_afp afp://username:email@example.com/volumename/ /Volumes/mntpnt
mkdir /Volumes/guest mount_afp "afp://;AUTH=No%20User%20Authent@myserver/guestVolume" /Volumes/guest The following shows how to use a username of "user:name" and password of "p@ssword": server.company.com/volumename/ at the mount point /Volumes/mntpnt:
mkdir /Volumes/myVolume mount_afp "afp://;AUTH=Client%20Krb%20v2@myserver/myVolume" /Volumes/myVolume
mount_afpcommand first appeared Mac OS X version 10.0. Kerberos authentication was added in Mac OS X version 10.2. This syntax (and manpage) was used for afpfs-ng's fuse implementation.
mount_afpsuccessfully mounted the volume directory.
- The server volume could not be mounted.
|February 1, 2008||Mac OS X|