|MAKEWHATIS(8)||System Manager's Manual||MAKEWHATIS(8)|
makewhatis — index
makewhatis utility extracts keywords
from UNIX manuals and indexes them in a database for
fast retrieval by apropos(1),
makewhatis creates a
database in each dir using the files
in that directory. Existing databases are replaced. If a directory contains
no manual pages, no database is created in that directory. If
dir is not provided,
makewhatis uses the default paths stipulated by
The arguments are as follows:
- Use all directories and files found below dir ....
- Specify an alternative configuration file in man.conf(5) format.
- Display all files added or removed to the index. With a second
-D, also show all keywords added for each file.
- Merge (remove and re-add) file ... to the database in dir.
- Do not create or modify any database; scan and parse only, and print manual page names and descriptions to standard output.
- Print warnings about potential problems with manual pages to the standard error output.
- Quickly build reduced-size databases by reading only the NAME sections of manuals. The resulting databases will usually contain names and descriptions only.
- Use UTF-8 encoding instead of ASCII for strings stored in the databases.
- Check the given files for potential problems.
-p. All diagnostic messages are printed to the standard output; the standard error output is not used.
- Remove file ... from the database in dir. If that causes the database to become empty, also delete the database file.
If fatal parse errors are encountered while parsing, the offending file is printed to stderr, omitted from the index, and the parse continues with the next input file.
- A colon-separated list of directories to create databases in. Ignored if a
dir argument or the
-toption is specified.
- A database of manpages relative to the directory of the file. This file is portable across architectures and systems, so long as the manpage hierarchy it indexes does not change.
- The default man(1) configuration file.
makewhatis utility exits with one of
the following values:
- No errors occurred.
- Invalid command line arguments were specified. No input files have been read.
- An operating system error occurred, for example memory exhaustion or an
error accessing input files. Such errors cause
makewhatisto exit at once, possibly in the middle of parsing or formatting a file. The output databases are corrupt and should be removed.
makewhatis utility first appeared in
2BSD. It was rewritten in
perl(1) for OpenBSD
2.7 and in C for OpenBSD 5.6.
The dir argument first appeared in
NetBSD 1.0; the options
in OpenBSD 2.7; the option
-u in OpenBSD 3.4; and the
-aCDnQT in OpenBSD
Bill Joy wrote the original
makewhatis in February
1979, Marc Espie started the Perl version in 2000,
and the current version of
makewhatis was written by
|May 17, 2017||Linux 6.3.2-arch1-1|