|PPPD(8)||System Manager's Manual||PPPD(8)|
pppd - 点对点协议守护进程
pppd [ tty_name ] [ speed ] [ options ]
点对点协议 (PPP) 提供一种在点对点串列线路上传输资料流 (datagrams)的方法。PPP是由三个部份所组成的：一个在串列线 路上封装(encapsulating)资料流的方法，一个可延伸的连结控制 协定(LinkControlProtocol:LCP)，以及一些用来建立并配置不 同网路层协定的网路控制协定(NetworkControlProtocols:NCP)
封装的机制(scheme)是由核心中的驱动程式码来提供。pppd提供 基本的LCP，验证(authentication)的支援，以及一个用来建立 并配置网际网路协定(InternatProtocol(IP))（叫做IP控制 协定，IPCP）的NCP。
常用选项 FREQUENTLY USED OPTIONS
在该名称的设备上进行通讯。如果需要的话可以前置一个 "/dev/"字串。如果没有给设备名称，pppd将会使用控制 台的终端机(controllingteriminal)，并且产生(fork)出 来时将不会把自己放到背景去。
将波特率设为speed。在像是4.4BSD以及NetBSA的系 统上，可以指定任何速率。其他系统(e.g.SunOs)只允 许有限的几种速率。
- asyncmap <map>
把非同步(async)字元设为对照到。这个对照表 描述哪些控制字元不能在串列线路上成功地接收。pppd将 会要求彼端以两个位元组的逸出序列(escapesequence)来 传送这些字元。其参数是32位元的十六进位数字而每个 位元代表一个得避开(escape)的字元。位元0(00000001) 代表字元0x00；位元31(80000000)代表字元0x1f或 是^_。如果给了多个asyncmap选项，这些数值会以逻 辑的或(OR)合在一起。如果没有给asyncmap选项，将没 有非同步字元对照表会被加以协商来导引接收。这样彼端 将会避开所有的控制字元。
- 要求彼端在允许传送或接收网路封包之前先验证它自己。 This option is the default if the system has a default route. If neither this option nor the noauth option is specified, pppd will only allow the peer to use IP addresses to which the system does not already have a route.
- call name
- Read options from the file /etc/ppp/peers/name. This file may contain privileged options, such as noauth, even if pppd is not being run by root. The name string may not begin with / or include .. as a pathname component. The format of the options file is described below.
- connect script
使用以所指定的可执行指令或是shell指令来设定 串列线路。这个指令稿一般会使用"chat"程式来拨数据 机并开始远端ppp区段作业(session)。 A value for this option from a privileged source cannot be overridden by a non-privileged user.
- 使用硬体流量控制(i.e.RTS/CTS)来控制串列埠上的资料流。 If neither the crtscts, the nocrtscts, the cdtrcts nor the nocdtrcts option is given, the hardware flow control setting for the serial port is left unchanged. Some serial ports (such as Macintosh serial ports) lack a true RTS output. Such serial ports use this mode to implement unidirectional flow control. The serial port will suspend transmission when requested by the modem (via CTS) but will be unable to request the modem stop sending to the computer. This mode retains the ability to use DTR as a modem control line.
当IPCP协商完全成功时，增加一个预设递送路径到系统 的递送表，将彼端当作闸道器使用。这个项目在ppp连线 中断后会移除。
- disconnect script
在pppd已经终结该连线之后执行以所指定的可执行 指令或是shell指令。这个指令稿可以用来，例如，如果 硬体的数据机控制信号无法使用时，发出指令给数据机使 其挂断电话。 The disconnect script is not run if the modem has already hung up. A value for this option from a privileged source cannot be overridden by a non-privileged user.
- escape xx,yy,...
指定在传输上确实应该要避开的字元（不管对方是否有用 它的非同步控制字元对照表要求避开它们）。这些要被避 开的字元是以用逗号隔开的一串十六进位数字指定的。要 注意到几乎任何字元都可以用escape选项指定避开，不 像asyncmap选项只允许指定控制字元。不能避开的字元 是那些有十六进位值0x20-0x3f或是0x5e者。
- file name
从档案里读取选项（其格式叙述在后） The file must be readable by the user who has invoked pppd.
- init script
- Run the executable or shell command specified by script to initialize the serial line. This script would typically use the chat(8) program to configure the modem to enable auto answer. A value for this option from a privileged source cannot be overridden by a non-privileged user.
- 指定pppd应该在此串列设备上使用UUCP式的锁定以确 定对该设备为互斥(exclusive)存取。
- mru n
(Note that for IPv6 MRU must be at least 1280)
- mtu n
将MTU[MaximumTransmitUnit最大传输单元]的值设 为n。除非彼端经由MRU协商要求一个更小的值，pppd 将会要求核心网路程式码透过PPP网路界面所传送的资料 封包不超过n个位元组。
(Note that for IPv6 MTU must be at least 1280)
在LCP中开启"passive"选项。加上这个选项，pppd将 会试图初使一个连线；如果没有从彼端接收到回应，那么 pppd将只会被动地等待从彼端所传来的一个有效LCP封 包（代替结束离开，就像它在没有这个选项时所作的）。
设定本地以及／或是远端界面的IP位址。两者之中的任 何一个都可以省略。该IP位址可以利用主机名称或者是 十进位数值加小数点符号指定(e.g.188.8.131.52)。 预设的本地位址是系统的（第一个）IP位址（除非有加上 noipdefault选项）。远端位址如果没有在任何选项中指 定的话将从彼端取得。因此，在简单的案例中，这个选项 不是必须的。如果有一个本地以及／或是远端的IP位址 以这个选项加以指定的话，pppd将不会接受在IPCP协商 中从彼端所传来不同的值，除非加上ipcp-accept-local 以及／或是ipcp-accept-remote选项，个别地。
- ipv6 <local_interface_identifier>,<remote_interface_identifier>
- Set the local and/or remote 64-bit interface identifier. Either one may be omitted. The identifier must be specified in standard ascii notation of IPv6 addresses (e.g. ::dead:beef). If the ipv6cp-use-ipaddr option is given, the local identifier is the local IPv4 address (see above). On systems which supports a unique persistent id, such as EUI-48 derived from the Ethernet MAC address, ipv6cp-use-persistent option can be used to replace the ipv6 <local>,<remote> option. Otherwise the identifier is randomized.
- active-filter filter-expression
- Specifies a packet filter to be applied to data packets to determine which packets are to be regarded as link activity, and therefore reset the idle timer, or cause the link to be brought up in demand-dialling mode. This option is useful in conjunction with the idle option if there are packets being sent or received regularly over the link (for example, routing information packets) which would otherwise prevent the link from ever appearing to be idle. The filter-expression syntax is as described for tcpdump(1), except that qualifiers which are inappropriate for a PPP link, such as ether and arp, are not permitted. Generally the filter expression should be enclosed in single-quotes to prevent whitespace in the expression from being interpreted by the shell. This option is currently only available under NetBSD, and then only if both the kernel and pppd were compiled with PPP_FILTER defined.
- allow-ip address(es)
- Allow peers to use the given IP address or subnet without authenticating themselves. The parameter is parsed as for each element of the list of allowed IP addresses in the secrets files (see the AUTHENTICATION section below).
- bsdcomp nr,nt
- Request that the peer compress packets that it sends, using the BSD-Compress scheme, with a maximum code size of nr bits, and agree to compress packets sent to the peer with a maximum code size of nt bits. If nt is not specified, it defaults to the value given for nr. Values in the range 9 to 15 may be used for nr and nt; larger values give better compression but consume more kernel memory for compression dictionaries. Alternatively, a value of 0 for nr or nt disables compression in the corresponding direction. Use nobsdcomp or bsdcomp 0 to disable BSD-Compress compression entirely.
- Use a non-standard hardware flow control (i.e. DTR/CTS) to control the flow of data on the serial port. If neither the crtscts, the nocrtscts, the cdtrcts nor the nocdtrcts option is given, the hardware flow control setting for the serial port is left unchanged. Some serial ports (such as Macintosh serial ports) lack a true RTS output. Such serial ports use this mode to implement true bi-directional flow control. The sacrifice is that this flow control mode does not permit using DTR as a modem control line.
- chap-interval n
- chap-max-challenge n
- chap-restart n
- connect-delay n
- Wait for up n milliseconds after the connect script finishes for a valid PPP packet from the peer. At the end of this time, or when a valid PPP packet is received from the peer, pppd will commence negotiation by sending its first LCP packet. The default value is 1000 (1 second). This wait period only applies if the connect or pty option is used.
- 递增侦错层级（与-d相同）。如果加上这个选项，pppd 将以可供阅读的格式记录所有传送或接收的控制封包内容。 这些封包透过syslog以facilitydaemon还有level debug加以记录。该资讯可以适当设定/etc/syslog.conf 来导向到一个档案去。（参阅syslog.conf(5)）。(如果 pppd以开启扩充侦错(extradebugging)编译的话，它将 会使用facilitylocal2取代daemon来记录讯息）。
- Disable asyncmap negotiation, forcing all control characters to be escaped for both the transmit and the receive direction.
- Disable MRU [Maximum Receive Unit] negotiation. With this option, pppd will use the default MRU value of 1500 bytes for both the transmit and receive direction.
- deflate nr,nt
- Request that the peer compress packets that it sends, using the Deflate scheme, with a maximum window size of 2**nr bytes, and agree to compress packets sent to the peer with a maximum window size of 2**nt bytes. If nt is not specified, it defaults to the value given for nr. Values in the range 9 to 15 may be used for nr and nt; larger values give better compression but consume more kernel memory for compression dictionaries. Alternatively, a value of 0 for nr or nt disables compression in the corresponding direction. Use nodeflate or deflate 0 to disable Deflate compression entirely. (Note: pppd requests Deflate compression in preference to BSD-Compress if the peer can do either.)
- Initiate the link only on demand, i.e. when data traffic is present. With
this option, the remote IP address must be specified by the user on the
command line or in an options file. Pppd will initially configure the
interface and enable it for IP traffic without connecting to the peer.
When traffic is available, pppd will connect to the peer and perform
negotiation, authentication, etc. When this is completed, pppd will
commence passing data packets (i.e., IP packets) across the link.
The demand option implies the persist option. If this behaviour is not desired, use the nopersist option after the demand option. The idle and holdoff options are also useful in conjuction with the demand option.
- domain d
新增领域名称到本地主机名称以支援验证。例如，如 果gethostname()回应porsche这个名称，但是完整合 格的领域名称是porsche.Quotron.COM的话，你可以使用 domain选项来将领域名称设为Quotron.COM。
Pppd would then use the name porsche.Quotron.COM for looking up secrets in the secrets file, and as the default name to send to the peer when authenticating itself to the peer. This option is privileged.
- With the dryrun option, pppd will print out all the option values which have been set and then exit, after parsing the command line and options files and checking the option values, but before initiating the link. The option values are logged at level info, and also printed to standard output unless the device on standard output is the device that pppd would be using to communicate with the peer.
- With the dump option, pppd will print out all the option values which have been set. This option is like the dryrun option except that pppd proceeds as normal rather than exiting.
- endpoint <epdisc>
- Sets the endpoint discriminator sent by the local machine to the peer during multilink negotiation to <epdisc>. The default is to use the MAC address of the first ethernet interface on the system, if any, otherwise the IPv4 address corresponding to the hostname, if any, provided it is not in the multicast or locally-assigned IP address ranges, or the localhost address. The endpoint discriminator can be the string null or of the form type:value, where type is a decimal number or one of the strings local, IP, MAC, magic, or phone. The value is an IP address in dotted-decimal notation for the IP type, or a string of bytes in hexadecimal, separated by periods or colons for the other types. For the MAC type, the value may also be the name of an ethernet or similar network interface. This option is currently only available under Linux.
- When logging the contents of PAP packets, this option causes pppd to exclude the password string from the log. This is the default.
- holdoff n
- Specifies how many seconds to wait before re-initiating the link after it terminates. This option only has any effect if the persist or demand option is used. The holdoff period is not applied if the link was terminated because it was idle.
- idle n
- Specifies that pppd should disconnect if the link is idle for n seconds. The link is idle when no data packets (i.e. IP packets) are being sent or received. Note: it is not advisable to use this option with the persist option without the demand option. If the active-filter option is given, data packets which are rejected by the specified activity filter also count as the link being idle.
- 加上这个选项的话，pppd将会接受彼端对于本地IP位址 的意见，即使本地的IP位址已经在某个选项中指定。
- 加上这个选项的话，pppd将会接受彼端对于它的IP位址 的意见，即使远端的IP位址已经在某个选项中指定。
- ipcp-max-configure n
- ipcp-max-failure n
- 将开始传送配置拒绝(configure-Rejects)之前的IPCP配 置未接收(configure-NAKs)的最大数目以取代n（预设 为10）。
- ipcp-max-terminate n
将IPCP终结要求(terminate-request)传输的最大数目设 为 n（预设为3）。
- ipcp-restart n
- ipparam string
- Provides an extra parameter to the ip-up and ip-down scripts. If this option is given, the string supplied is given as the 6th parameter to those scripts.
- ipv6cp-max-configure n
- Set the maximum number of IPv6CP configure-request transmissions to n (default 10).
- ipv6cp-max-failure n
- Set the maximum number of IPv6CP configure-NAKs returned before starting to send configure-Rejects instead to n (default 10).
- ipv6cp-max-terminate n
- Set the maximum number of IPv6CP terminate-request transmissions to n (default 3).
- ipv6cp-restart n
- Set the IPv6CP restart interval (retransmission timeout) to n seconds (default 3).
- Enable the IPXCP and IPX protocols. This option is presently only supported under Linux, and only if your kernel has been configured to include IPX support.
- ipx-network n
- Set the IPX network number in the IPXCP configure request frame to n, a hexadecimal number (without a leading 0x). There is no valid default. If this option is not specified, the network number is obtained from the peer. If the peer does not have the network number, the IPX protocol will not be started.
- ipx-node n:m
- Set the IPX node numbers. The two node numbers are separated from each other with a colon character. The first number n is the local node number. The second number m is the peer's node number. Each node number is a hexadecimal number, at most 10 digits long. The node numbers on the ipx-network must be unique. There is no valid default. If this option is not specified then the node numbers are obtained from the peer.
- ipx-router-name <string>
- Set the name of the router. This is a string and is sent to the peer as information data.
- ipx-routing n
- Set the routing protocol to be received by this option. More than one instance of ipx-routing may be specified. The 'none' option (0) may be specified as the only instance of ipx-routing. The values may be 0 for NONE, 2 for RIP/SAP, and 4 for NLSP.
- Accept the peer's NAK for the node number specified in the ipx-node option. If a node number was specified, and non-zero, the default is to insist that the value be used. If you include this option then you will permit the peer to override the entry of the node number.
- Accept the peer's NAK for the network number specified in the ipx-network option. If a network number was specified, and non-zero, the default is to insist that the value be used. If you include this option then you will permit the peer to override the entry of the node number.
- Use the peer's network number specified in the configure request frame. If a node number was specified for the peer and this option was not specified, the peer will be forced to use the value which you have specified.
- ipxcp-max-configure n
- Set the maximum number of IPXCP configure request frames which the system will send to n. The default is 10.
- ipxcp-max-failure n
- Set the maximum number of IPXCP NAK frames which the local system will send before it rejects the options. The default value is 3.
- ipxcp-max-terminate n
- Set the maximum nuber of IPXCP terminate request frames before the local system considers that the peer is not listening to them. The default value is 3.
- kdebug n
- 开启核心层级中的PPP驱动程式侦错码。The argument values depend on the specific kernel driver, but in general a value of 1 will enable general kernel debug messages. (Note that these messages are usually only useful for debugging the kernel driver itself.) For the Linux 2.2.x kernel driver, 参数n是一个 由下列值所组合的数字：1开启一般侦错讯息，2要求印 出所接收到的封包内容，而4要求印出传输的封包内容。 On most systems, messages printed by the kernel are logged by syslog(1) to a file as directed in the /etc/syslog.conf configuration file.
- Enables pppd to alter kernel settings as appropriate. Under Linux, pppd will enable IP forwarding (i.e. set /proc/sys/net/ipv4/ip_forward to 1) if the proxyarp option is used, and will enable the dynamic IP address option (i.e. set /proc/sys/net/ipv4/ip_dynaddr to 1) in demand mode if the local address changes.
- lcp-echo-failure n
如果有给这个选项，那么如果传送n个LCP回应要求没 有接收到有效的LCP回应回复的话pppd将会推测彼端是 死掉的。如果发生这种情形，pppd将会终结该连线。这个 选项的使用要求一个非零的lcp-echo-interval参数值。 这个选项可以用在硬体数据机控制线路无法使用的情况下 当实际连线被中断之后（e.g.,数据机已经挂断）终结 pppd的执行。
- lcp-echo-interval n
- 如果有给这个选项，pppd每秒将会送出一个LCP回 应要求(echo-request)封包(frame)给彼端。在Linux系 统下，回应要求在n秒内没有从彼端接收到封包时会被送 出。一般彼端应该以传送一个回应回复(echo-reply)来反 应该回应要求。这个选项可以与lcp-echo-failure选项 一起使用来侦测不再连线的彼端。
- lcp-max-configure n
- lcp-max-failure n
将开始传送配置拒绝(configure-Rejects)之前的LCP配 置未接收(configure-NAKs)的最大数目设置为n（预设 为10）。
- lcp-max-terminate n
- lcp-restart n
- 将LCP重新开始的间隔（重新传输的时间限制）设为 秒钟（预设为3）。
- Sets the logical name of the link to name. Pppd will create a file named ppp-name.pid in /var/run (or /etc/ppp on some systems) containing its process ID. This can be useful in determining which instance of pppd is responsible for the link to a given peer system. This is a privileged option.
- 不要使用数据机控制线路。 With this option, pppd will ignore the state of the CD (Carrier Detect) signal from the modem and will not change the state of the DTR (Data Terminal Ready) signal.
- logfd n
- Send log messages to file descriptor n. Pppd will send log messages to at most one file or file descriptor (as well as sending the log messages to syslog), so this option and the logfile option are mutually exclusive. The default is for pppd to send log messages to stdout (file descriptor 1), unless the serial port is already open on stdout.
- logfile filename
- Append log messages to the file filename (as well as sending the log messages to syslog). The file is opened with the privileges of the user who invoked pppd, in append mode.
- 使用系统密码资料库验证使用PAP的彼端。 and record the user in the system wtmp file. Note that the peer must have an entry in the /etc/ppp/pap-secrets file as well as the system password database to be allowed access.
- maxconnect n
- Terminate the connection when it has been available for network traffic for n seconds (i.e. n seconds after the first network control protocol comes up).
- maxfail n
- Terminate after n consecutive failed connection attempts. A value of 0 means no limit. The default value is 10.
- 使用数据机控制线路。This option is the default. With this option, pppd will wait for the CD (Carrier Detect) signal from the modem to be asserted when opening the serial device (unless a connect script is specified), and it will drop the DTR (Data Terminal Ready) signal briefly when the connection is terminated and before executing the connect script. 在Ultrix上，这个选项会实作硬 体流量控制，像crtsct选项作的。
- Enables the use of PPP multilink; this is an alias for the `multilink' option. This option is currently only available under Linux.
- Enables the use of short (12-bit) sequence numbers in multilink headers, as opposed to 24-bit sequence numbers. This option is only available under Linux, and only has any effect if multilink is enabled (see the multilink option).
- mrru n
- Sets the Maximum Reconstructed Receive Unit to n. The MRRU is the maximum size for a received packet on a multilink bundle, and is analogous to the MRU for the individual links. This option is currently only available under Linux, and only has any effect if multilink is enabled (see the multilink option).
- ms-dns <addr>
- If pppd is acting as a server for Microsoft Windows clients, this option allows pppd to supply one or two DNS (Domain Name Server) addresses to the clients. The first instance of this option specifies the primary DNS address; the second instance (if given) specifies the secondary DNS address. (This option was present in some older versions of pppd under the name dns-addr.)
- ms-wins <addr>
- If pppd is acting as a server for Microsoft Windows or "Samba" clients, this option allows pppd to supply one or two WINS (Windows Internet Name Services) server addresses to the clients. The first instance of this option specifies the primary WINS address; the second instance (if given) specifies the secondary WINS address.
- Enables the use of the PPP multilink protocol. If the peer also supports multilink, then this link can become part of a bundle between the local system and the peer. If there is an existing bundle to the peer, pppd will join this link to that bundle, otherwise pppd will create a new bundle. See the MULTILINK section below. This option is currently only available under Linux.
- name name
- 将本地系统的名称设为用来进行验证。 This is a privileged option. With this option, pppd will use lines in the secrets files which have name as the second field when looking for a secret to use in authenticating the peer. In addition, unless overridden with the user option, name will be used as the name to send to the peer when authenticating the local system to the peer. (Note that pppd does not append the domain name to name.)
- netmask n
把该界面网路掩码设为，这是一个以″十进位数值加 小数点″("decimaldot")符号表示的32位元网路掩码 (e.g.255.255.255.0)。If this option is given, the value specified is ORed with the default netmask. The default netmask is chosen based on the negotiated remote IP address; it is the appropriate network mask for the class of the remote IP address, ORed with the netmasks for any non point-to-point network interfaces in the system which are on the same network. (Note: on some platforms, pppd will always use 255.255.255.255 for the netmask, if that is the only appropriate value for a point-to-point interface.)
- Disable Address/Control compression in both directions (send and receive).
- Do not require the peer to authenticate itself. This option is privileged.
- Disables BSD-Compress compression; pppd will not request or agree to compress packets using the BSD-Compress scheme.
- Disable CCP (Compression Control Protocol) negotiation. This option should only be required if the peer is buggy and gets confused by requests from pppd for CCP negotiation.
- Disable hardware flow control (i.e. RTS/CTS) on the serial port. If neither the crtscts nor the nocrtscts nor the cdtrcts nor the nocdtrcts option is given, the hardware flow control setting for the serial port is left unchanged.
- This option is a synonym for nocrtscts. Either of these options will disable both forms of hardware flow control.
- Disable the defaultroute option. The system administrator who wishes to prevent users from creating default routes with pppd can do so by placing this option in the /etc/ppp/options file.
- Disables Deflate compression; pppd will not request or agree to compress packets using the Deflate scheme.
- Don't detach from the controlling terminal. Without this option, if a serial device other than the terminal on the standard input is specified, pppd will fork to become a background process.
- Disables pppd from sending an endpoint discriminator to the peer or accepting one from the peer (see the MULTILINK section below). This option should only be required if the peer is buggy.
- Disable IPCP negotiation and IP communication. This option should only be required if the peer is buggy and gets confused by requests from pppd for IPCP negotiation.
- Disable IPv6CP negotiation and IPv6 communication. This option should only be required if the peer is buggy and gets confused by requests from pppd for IPv6CP negotiation.
- 关闭在没有指定本地IP位址时所进行的预设动作，这是 用来由从主机名称决定（如果可能的话）决定本地IP位 址。加上这个选项的话，彼端将必须在进行IPCP协商时 （除非在指令列或在选项档中明确地指定它）提供本地的 IP位址。
- Disable the IPXCP and IPX protocols. This option should only be required if the peer is buggy and gets confused by requests from pppd for IPXCP negotiation.
- Opposite of the ktune option; disables pppd from changing system settings.
- Do not send log messages to a file or file descriptor. This option cancels the logfd and logfile options.
- Disable magic number negotiation. With this option, pppd cannot detect a looped-back line. This option should only be needed if the peer is buggy.
- Disables the use of PPP multilink. This option is currently only available under Linux.
- Disables the use of short (12-bit) sequence numbers in the PPP multilink protocol, forcing the use of 24-bit sequence numbers. This option is currently only available under Linux, and only has any effect if multilink is enabled.
- Disables the use of PPP multilink. This option is currently only available under Linux.
- Disable protocol field compression negotiation in both the receive and the transmit direction.
- Exit once a connection has been made and terminated. This is the default unless the persist or demand option has been specified.
- Do not accept or agree to Predictor-1 compression.
- Disable the proxyarp option. The system administrator who wishes to prevent users from creating proxy ARP entries with pppd can do so by placing this option in the /etc/ppp/options file.
- Normally, pppd requires a terminal device. With this option, pppd will allocate itself a pseudo-tty master/slave pair and use the slave as its terminal device. Pppd will create a child process to act as a `character shunt' to transfer characters between the pseudo-tty master and its standard input and output. Thus pppd will transmit characters on its standard output and receive characters on its standard input even if they are not terminal devices. This option increases the latency and CPU overhead of transferring data over the ppp interface as all of the characters sent and received must flow through the character shunt process. An explicit device name may not be given if this option is used.
- Disable Van Jacobson style TCP/IP header compression in both the transmit and the receive direction.
- Disable the connection-ID compression option in Van Jacobson style TCP/IP header compression. With this option, pppd will not omit the connection-ID byte from Van Jacobson compressed TCP/IP headers, nor ask the peer to do so.
- Indicates that all secrets in the /etc/ppp/pap-secrets file which are used for checking the identity of the peer are encrypted, and thus pppd should not accept a password which, before encryption, is identical to the secret from the /etc/ppp/pap-secrets file.
- pap-max-authreq n
- pap-restart n
- pap-timeout n
- Set the maximum time that pppd will wait for the peer to authenticate itself with PAP to n seconds (0 means no limit).
- pass-filter filter-expression
- Specifies a packet filter to applied to data packets being sent or received to determine which packets should be allowed to pass. Packets which are rejected by the filter are silently discarded. This option can be used to prevent specific network daemons (such as routed) using up link bandwidth, or to provide a basic firewall capability. The filter-expression syntax is as described for tcpdump(1), except that qualifiers which are inappropriate for a PPP link, such as ether and arp, are not permitted. Generally the filter expression should be enclosed in single-quotes to prevent whitespace in the expression from being interpreted by the shell. Note that it is possible to apply different constraints to incoming and outgoing packets using the inbound and outbound qualifiers. This option is currently only available under NetBSD, and then only if both the kernel and pppd were compiled with PPP_FILTER defined.
- Do not exit after a connection is terminated; instead try to reopen the connection.
- plugin filename
- Load the shared library object file filename as a plugin. This is a privileged option.
- Request that the peer compress frames that it sends using Predictor-1 compression, and agree to compress transmitted frames with Predictor-1 if requested. This option has no effect unless the kernel driver supports Predictor-1 compression.
- privgroup group-name
- Allows members of group group-name to use privileged options. This is a privileged option. Use of this option requires care as there is no guarantee that members of group-name cannot use pppd to become root themselves. Consider it equivalent to putting the members of group-name in the kmem or disk group.
- 以彼端的IP位址以及该系统的乙太网路位址增加一个项 目到系统的ARP[AddressResolutionProtocol位址解 译协定]表格。 This will have the effect of making the peer appear to other systems to be on the local ethernet.
- pty script
- Specifies that the command script is to be used to communicate rather than a specific terminal device. Pppd will allocate itself a pseudo-tty master/slave pair and use the slave as its terminal device. The script will be run in a child process with the pseudo-tty master as its standard input and output. An explicit device name may not be given if this option is used. (Note: if the record option is used in conjuction with the pty option, the child process will have pipes on its standard input and output.)
- With this option, pppd will accept all control characters from the peer, including those marked in the receive asyncmap. Without this option, pppd will discard those characters as specified in RFC1662. This option should only be needed if the peer is buggy.
- record filename
- Specifies that pppd should record all characters sent and received to a file named filename. This file is opened in append mode, using the user's user-ID and permissions. This option is implemented using a pseudo-tty and a process to transfer characters between the pseudo-tty and the real serial device, so it will increase the latency and CPU overhead of transferring data over the ppp interface. The characters are stored in a tagged format with timestamps, which can be displayed in readable form using the pppdump(8) program.
- remotename name
- With this option, pppd will not agree to authenticate itself to the peer using CHAP.
- With this option, pppd will not agree to authenticate itself to the peer using PAP.
- Require the peer to authenticate itself using CHAP [Challenge Handshake Authentication Protocol] authentication.
- Require the peer to authenticate itself using PAP [Password Authentication Protocol] authentication.
- When logging the contents of PAP packets, this option causes pppd to show the password string in the log message.
- 加上这个选项，pppd将不会传输LCP封包来初使一个连 线一直到从彼端接收到一个有效的LCP封包。（就像是给 旧版pppd使用的"passive"选项）。
- Use synchronous HDLC serial encoding instead of asynchronous. The device used by pppd with this option must have sync support. Currently supports Microgate SyncLink adapters under Linux and FreeBSD 2.2.8 and later.
- With this option, pppd will detach from its controlling terminal once it has successfully established the ppp connection (to the point where the first network control protocol, usually the IP control protocol, has come up).
- 强迫主机名称使用本地系统的名称来进行验证。（这会盖过name选项）。 This option is not normally needed since the name option is privileged.
- Ask the peer for up to 2 DNS server addresses. The addresses supplied by the peer (if any) are passed to the /etc/ppp/ip-up script in the environment variables DNS1 and DNS2. In addition, pppd will create an /etc/ppp/resolv.conf file containing one or two nameserver lines with the address(es) supplied by the peer.
- user name
- vj-max-slots n
- Sets the number of connection slots to be used by the Van Jacobson TCP/IP header compression and decompression code to n, which must be between 2 and 16 (inclusive).
- welcome script
- Run the executable or shell command specified by script before initiating PPP negotiation, after the connect script (if any) has completed. A value for this option from a privileged source cannot be overridden by a non-privileged user.
选项文件 OPTIONS FILES
选项可以从档案取出使用就如同使用命令列一般。pppd在查看指 令列之前先从档案/etc/ppp/options以及~/.ppprc读取选项。 ttyname (in that order) before processing the options on the command line. (In fact, the command-line options are scanned to find the terminal name before the options.ttyname file is read.) In forming the name of the options.ttyname file, the initial /dev/ is removed from the terminal name, and any remaining / characters are replaced with dots.
一个选项档案以空白字元为界被剖析成一串单字。空白字元可以用 双引号(")包括在一个单字里。倒斜线引用其后的字元。而hash (#)符号开始一段注解持续到该行结束。 There is no restriction on using the file or call options within an options file.
pppd 提供系统管理人员充份的存取控制能力这表示以PPP存取一 台伺服机器可以提供给合法的使用者使用而不必担心危及该伺服器 或所在网路的安全性。这有一部份是以/etc/ppp/options档案来 提供，在这里系统管理人员可以放置在执行pppd的时候用来要求 验证的选项，而部份是由PAP以及CHAP暗号档案来提供，其中 系统管理人员可以限制个别的使用者可以使用的一群IP位址。
The default behaviour of pppd is to allow an unauthenticated peer to use a given IP address only if the system does not already have a route to that IP address. For example, a system with a permanent connection to the wider internet will normally have a default route, and thus all peers will have to authenticate themselves in order to set up a connection. On such a system, the auth option is the default. On the other hand, a system where the PPP link is the only connection to the internet will not normally have a default route, so the peer will be able to use almost any IP address without authenticating itself.
As indicated above, some security-sensitive options are privileged, which means that they may not be used by an ordinary non-privileged user running a setuid-root pppd, either on the command line, in the user's ~/.ppprc file, or in an options file read using the file option. Privileged options may be used in /etc/ppp/options file or in an options file read using the call option. If pppd is being run by the root user, privileged options can be used without restriction.
When opening the device, pppd uses either the invoking user's user ID or the root UID (that is, 0), depending on whether the device name was specified by the user or the system administrator. If the device name comes from a privileged source, that is, /etc/ppp/options or an options file read using the call option, pppd uses full root privileges when opening the device. Thus, by creating an appropriate file under /etc/ppp/peers, the system administrator can allow users to establish a ppp connection via a device which they would not normally have permission to access. Otherwise pppd uses the invoking user's real UID when opening the device.
Authentication is the process whereby one peer convinces the other of its identity. This involves the first peer sending its name to the other, together with some kind of secret information which could only come from the genuine authorized user of that name. In such an exchange, we will call the first peer the "client" and the other the "server". The client has a name by which it identifies itself to the server, and the server also has a name by which it identifies itself to the client. Generally the genuine client shares some secret (or password) with the server, and authenticates itself by proving that it knows that secret. Very often, the names used for authentication correspond to the internet hostnames of the peers, but this is not essential.
At present, pppd supports two authentication protocols: the Password Authentication Protocol (PAP) and the Challenge Handshake Authentication Protocol (CHAP). PAP involves the client sending its name and a cleartext password to the server to authenticate itself. In contrast, the server initiates the CHAP authentication exchange by sending a challenge to the client (the challenge packet includes the server's name). The client must respond with a response which includes its name plus a hash value derived from the shared secret and the challenge, in order to prove that it knows the secret.
The PPP protocol, being symmetrical, allows both peers to require the other to authenticate itself. In that case, two separate and independent authentication exchanges will occur. The two exchanges could use different authentication protocols, and in principle, different names could be used in the two exchanges.
pppd预设的动作是如果有要求就同意进行验证，并且不要求从彼 端做验证。然而如果没有可以用来验证的暗号则pppd将不会同意 以特殊的协定来验证它自己。
验证的基础是由暗号档案选择的暗号（/etc/ppp/pap-secrets是 给PAP使用的，/etc/ppp/chap-secrets则是给CHAP使用）。 这两个暗号档案都具有相同的格式，而且两者都可以储放暗号给数 种伺服器（验证彼端）及客户（被验证端）组合使用。注意pppd 可以最为伺服端以及客户端，而且如果需要的话两方可以使用不同 的协定。
一个暗号档案如同选项档案一般被剖析成单字。一个暗号是由最少 包含3个单字的一行所指定，依序是客户，伺服器，暗号。在同 一行中任何跟在其后的单字都被当作是给客户的可接受IP位址列 表。如果该行只有3个单字，这假设任何IP位址都可以；不允 许所有的IP位址的话，使用"-"。如果暗号是以'@'开始，其 后所接的单字将被假设为可以从中读取暗号的档案名称。而以一个 "*"字元作为客户或伺服端的名称会符合任何名称。在选择一个暗 号时，pppd会选择最符合的，i.e.最少万用字元的那个。
如此一个暗号档案包含用来验证其它主机，以及用来为其它主机验 证自己两者的暗号。选择使用哪个暗号是根据该主机（本地名称） 以及其彼端（远端名称）而定。本地名称的设定如下：
If the secret starts with an `@', what follows is assumed to be the name of a file from which to read the secret. A "*" as the client or server name matches any name. When selecting a secret, pppd takes the best match, i.e. the match with the fewest wildcards.
Any following words on the same line are taken to be a list of acceptable IP addresses for that client. If there are only 3 words on the line, or if the first word is "-", then all IP addresses are disallowed. To allow any address, use "*". A word starting with "!" indicates that the specified address is not acceptable. An address may be followed by "/" and a number n, to indicate a whole subnet, i.e. all addresses which have the same value in the most significant n bits. In this form, the address may be followed by a plus sign ("+") to indicate that one address from the subnet is authorized, based on the ppp network interface unit number in use. In this case, the host part of the address will be set to the unit number plus one.
Thus a secrets file contains both secrets for use in authenticating other hosts, plus secrets which we use for authenticating ourselves to others. When pppd is authenticating the peer (checking the peer's identity), it chooses a secret with the peer's name in the first field and the name of the local system in the second field. The name of the local system defaults to the hostname, with the domain name appended if the domain option is used. This default can be overridden with the name option, except when the usehostname option is used.
When pppd is choosing a secret to use in authenticating itself to the peer, it first determines what name it is going to use to identify itself to the peer. This name can be specified by the user with the user option. If this option is not used, the name defaults to the name of the local system, determined as described in the previous paragraph. Then pppd looks for a secret with this name in the first field and the peer's name in the second field. Pppd will know the name of the peer if CHAP authentication is being used, because the peer will have sent it in the challenge packet. However, if PAP is being used, pppd will have to determine the peer's name from the options specified by the user. The user can specify the peer's name directly with the remotename option. Otherwise, if the remote IP address was specified by a name (rather than in numeric form), that name will be used as the peer's name. Failing that, pppd will use the null string as the peer's name.
当以PAP验证彼端时，一个""暗号符合任何由彼端所提供密码。 如果密码不符合暗号，密码被以crypt()编码并且再次检查暗号； 因此验证彼端的暗号可以编码方式储放。
如果指定有login选项， 使用者名称以及密码也会被以系统的密码资料库检查。因此系统管 理人员可以设定pap-secrets档案以便只允许某些使用者以PPP 连线，并且限制每个使用者可以使用一些IP位址。 Typically, when using the login option, the secret in /etc/ppp/pap-secrets would be "", which will match any password supplied by the peer. This avoids the need to have the same secret in two places.
验证必须在IPCP（或任何其它网路控制协定）开始之前被完全地 满足。如果验证失败，pppd将会终结连线（关闭LCP）。如果 IPCP协商出一个无法接受的远端主机IP位址，IPCP将会关闭。 IP封包只有在IPCP打开的时候才能传送或接收。
即使本地主机一般会要求验证，在某些案例中会希望允一些无法验 证它们自己的主机连线并使用所限制的IP位址其中之一。如果彼 在被要求时拒绝验证它自己，pppd将会把它当成等于是在使用者 名称以及密码上使用空字串来以PAP验证。所以，借由增加一行 指定空字串为客户以及密码到pap-secrets档案去，允许拒绝验 证自己的主机进行有限制的存取是可能的。
当IPCP协商成功地完成时，pppd将会通知核心该ppp界面本地 以及远端的IP位址。这足够用来建立一个主机到该连线远端的递 送路径，该路径将使两端能交换IP封包。与其它的机器进行通讯 往往需要更进一步地修改递送表格(routingtables)以及／或是 ARP（位址解译协定）表格。在某些案例中这将透过routed或是 gated隐形程式的动作自动地完成，但是在大部分的案例中需要更 进一步的介入。
有时候会希望透过远端主机来增加一个预设递送路径，像是在一台 只透过ppp界面连线到Internet的机器。此defaultroute选 项使得pppd在IPCP完成时建立起这么一个预设的递送路径，并 且在该线路被终结时将之删除。
在某些情况下会希望使用proxyARP，例如在一台连结到区域网 路的伺服机器上，为了能够允许其它的主机与远端主机进行通讯。 proxyarp选项引发pppd去寻找一个与远端主机在相同子网路上 的网路界面（一个支援广播(boardcast)以及ARP的界面，不但要 是可用的并且不是一个点对点或回授界面）。如果找到，pppd会 以该远端主机的IP位址以及所找到的网路界面之硬体位址建立一 个永久的，公开的ARP项目。
When the demand option is used, the interface IP addresses have already been set at the point when IPCP comes up. If pppd has not been able to negotiate the same addresses that it used to configure the interface (for example when the peer is an ISP that uses dynamic IP address assignment), pppd has to change the interface IP addresses to the negotiated addresses. This may disrupt existing connections, and the use of demand dialling with peers that do dynamic IP address assignment is not recommended.
Multilink PPP provides the capability to combine two or more PPP links between a pair of machines into a single `bundle', which appears as a single virtual PPP link which has the combined bandwidth of the individual links. Currently, multilink PPP is only supported under Linux.
Pppd detects that the link it is controlling is connected to the same peer as another link using the peer's endpoint discriminator and the authenticated identity of the peer (if it authenticates itself). The endpoint discriminator is a block of data which is hopefully unique for each peer. Several types of data can be used, including locally-assigned strings of bytes, IP addresses, MAC addresses, randomly strings of bytes, or E-164 phone numbers. The endpoint discriminator sent to the peer by pppd can be set using the endpoint option.
In circumstances the peer may send no endpoint discriminator or a non-unique value. The optional bundle option adds an extra string which is added to the peer's endpoint discriminator and authenticated identity when matching up links to be joined together in a bundle. The bundle option can also be used to allow the establishment of multiple bundles between the local system and the peer. Pppd uses a TDB database in /var/run/pppd.tdb to match up links.
Assuming that multilink is enabled and the peer is willing to negotiate multilink, then when pppd is invoked to bring up the first link to the peer, it will detect that no other link is connected to the peer and create a new bundle, that is, another ppp network interface unit. When another pppd is invoked to bring up another link to the peer, it will detect the existing bundle and join its link to it. Currently, if the first pppd terminates (for example, because of a hangup or a received signal) the bundle is destroyed.
范例 EXAMPLE S
The following examples assume that the /etc/ppp/options file contains the auth option (as in the default /etc/ppp/options file in the ppp distribution).
Probably the most common use of pppd is to dial out to an ISP. This can be done with a command such as
- pppd call isp
where the /etc/ppp/peers/isp file is set up by the system administrator to contain something like this:
- ttyS0 19200 crtscts
connect '/usr/sbin/chat -v -f /etc/ppp/chat-isp'
In this example, we are using chat to dial the ISP's modem and go through any logon sequence required. The /etc/ppp/chat-isp file contains the script used by chat; it could for example contain something like this:
- ABORT "NO CARRIER"
ABORT "NO DIALTONE"
ABORT "NO ANSWER"
ABORT "Username/Password Incorrect"
See the chat(8) man page for details of chat scripts.
Pppd can also be used to provide a dial-in ppp service for users. If the users already have login accounts, the simplest way to set up the ppp service is to let the users log in to their accounts and run pppd (installed setuid-root) with a command such as
- pppd proxyarp
To allow a user to use the PPP facilities, you need to allocate an IP address for that user's machine and create an entry in /etc/ppp/pap-secrets or /etc/ppp/chap-secrets (depending on which authentication method the PPP implementation on the user's machine supports), so that the user's machine can authenticate itself. For example, if Joe has a machine called "joespc" which is to be allowed to dial in to the machine called "server" and use the IP address joespc.my.net, you would add an entry like this to /etc/ppp/pap-secrets or /etc/ppp/chap-secrets:
- joespc server "joe's secret" joespc.my.net
Alternatively, you can create a username called (for example) "ppp", whose login shell is pppd and whose home directory is /etc/ppp. Options to be used when pppd is run this way can be put in /etc/ppp/.ppprc.
如果你的串列连线比直接以线路连接更复杂的话，你可能会需要做 些调整以便避开一些控制字元。特别是，通常避开XON(^Q)以及 XOFF(^S)是有用的，可以使用asyncmapa0000。如果该路径包 含telnet的话，你可能应该也要避开^](asyncmap200a0000)。 如果该路径包含rlogin的话，你将需要在执行rlogin的客户端 上使用escapeff选项，因为许多rlogin的实作并非是透通的； 它们将会从资料流中移除[0xff,0xff,0x73,0x73,跟随的任何 8位元组]这些序列。
讯息使用facilityLOG_DAEMON送到syslog隐形程式。（这个 可以藉著以所要的facility定义LOG_PPP巨集来重新编译pppd 加以改变。）为了能够看到错误以及侦错讯息，你将需要编辑你的 /etc/syslog.conf档案来将讯息导向到所希望的设备或档案。
debug选项使得所有送出以及接收的控制封包内容都被记录下来， 这是指所有的LCP,PAP,CHAP,或是IPCP封包。如果PPP协商 没有成功的话那么这可能会有用。如果在编译时期开启侦错功能的 话，pppd会使用facilityLOG_LOCAL2来取代LOG_DAEMON，而 且debug选项会使得额外的侦错讯息被记录下来。
The exit status of pppd is set to indicate whether any error was detected, or the reason for the link being terminated. The values used are:
- Pppd has detached, or otherwise the connection was successfully established and terminated at the peer's request.
- An immediately fatal error of some kind occurred, such as an essential system call failing, or running out of virtual memory.
- An error was detected in processing the options given, such as two mutually exclusive options being used.
- Pppd is not setuid-root and the invoking user is not root.
- The kernel does not support PPP, for example, the PPP kernel driver is not included or cannot be loaded.
- Pppd terminated because it was sent a SIGINT, SIGTERM or SIGHUP signal.
- The serial port could not be locked.
- The serial port could not be opened.
- The connect script failed (returned a non-zero exit status).
- The command specified as the argument to the pty option could not be run.
- The PPP negotiation failed, that is, it didn't reach the point where at least one network protocol (e.g. IP) was running.
- The peer system failed (or refused) to authenticate itself.
- The link was established successfully and terminated because it was idle.
- The link was established successfully and terminated because the connect time limit was reached.
- Callback was negotiated and an incoming call should arrive shortly.
- The link was terminated because the peer is not responding to echo requests.
- The link was terminated by the modem hanging up.
- The PPP negotiation failed because serial loopback was detected.
- The init script failed (returned a non-zero exit status).
- We failed to authenticate ourselves to the peer.
Pppd invokes scripts at various stages in its processing which can be used to perform site-specific ancillary processing. These scripts are usually shell scripts, but could be executable code files instead. Pppd does not wait for the scripts to finish. The scripts are executed as root (with the real and effective user-id set to 0), so that they can do things such as update routing tables or run privileged daemons. Be careful that the contents of these scripts do not compromise your system's security. Pppd runs the scripts with standard input, output and error redirected to /dev/null, and with an environment that is empty except for some environment variables that give information about the link. The environment variables that pppd sets are:
- The name of the serial tty device being used.
- The name of the network interface being used.
- The IP address for the local end of the link. This is only set when IPCP has come up.
- The IP address for the remote end of the link. This is only set when IPCP has come up.
- The authenticated name of the peer. This is only set if the peer authenticates itself.
- The baud rate of the tty device.
- The real user-id of the user who invoked pppd.
- The username of the real user-id that invoked pppd. This is always set.
For the ip-down and auth-down scripts, pppd also sets the following variables giving statistics for the connection:
- The number of seconds from when the PPP negotiation started until the connection was terminated.
- The number of bytes sent (at the level of the serial port) during the connection.
- The number of bytes received (at the level of the serial port) during the connection.
- The logical name of the link, set with the linkname option.
Pppd invokes the following scripts, if they exist. It is not an error if they don't exist.
- A program or script which is executed after the remote system successfully authenticates itself. It is executed with the parameters
- interface-name peer-name user-name tty-device speed
- Note that this script is not executed if the peer doesn't authenticate itself, for example when the noauth option is used.
- A program or script which is executed when the link goes down, if /etc/ppp/auth-up was previously executed. It is executed in the same manner with the same parameters as /etc/ppp/auth-up.
- 当线路可以传送以及接收IP封包时（也就是IPCP完成 时）执行的一支程式或指令稿。它是以界面的名称、终端 设备、速度、本地-IP-位址、远端-IP-位址为参数执行。
- interface-name tty-device speed local-IP-address remote-IP-address ipparam
- 当线路不再允许传送以及接收IP封包时执行的一支程式 或指令稿。这个指令稿可以用来回复/etc/ppp/ip-up指 令稿的影响。它以与ip-up指令稿相同的参数启动。
- Like /etc/ppp/ip-up, except that it is executed when the link is available for sending and receiving IPv6 packets. It is executed with the parameters
- interface-name tty-device speed local-link-local-address remote-link-local-address ipparam
- Similar to /etc/ppp/ip-down, but it is executed when IPv6 packets can no longer be transmitted on the link. It is executed with the same parameters as the ipv6-up script.
- A program or script which is executed when the link is available for sending and receiving IPX packets (that is, IPXCP has come up). It is executed with the parameters
- interface-name tty-device speed network-number local-IPX-node-address remote-IPX-node-address local-IPX-routing-protocol remote-IPX-routing-protocol local-IPX-router-name remote-IPX-router-name ipparam pppd-pid
- The local-IPX-routing-protocol and remote-IPX-routing-protocol field may be one of the following:
- NONE to indicate that there is no routing protocol
RIP to indicate that RIP/SAP should be used
NLSP to indicate that Novell NLSP should be used
RIP NLSP to indicate that both RIP/SAP and NLSP should be used
- A program or script which is executed when the link is no longer available for sending and receiving IPX packets. This script can be used for undoing the effects of the /etc/ppp/ipx-up script. It is invoked in the same manner and with the same parameters as the ipx-up script.
- /var/run/pppn.pid (BSD or Linux), /etc/ppp/pppn.pid (others)
- /var/run/ppp-name.pid (BSD or Linux), /etc/ppp/ppp-name.pid (others)
- Process-ID for pppd process for logical link name (see the linkname option).
由PAP验证所使用的使用者名称、密码以及IP位址。 This file should be owned by root and not readable or writable by any other user. Pppd will log a warning if this is not the case.
As for /etc/ppp/pap-secrets, this file should be owned by root and not readable or writable by any other user. Pppd will log a warning if this is not the case.
所要使用之串列埠的系统预设选项，在指令列之后读取。read after ~/.ppprc. In forming the ttyname part of this filename, an initial /dev/ is stripped from the port name (if present), and any slashes in the remaining part are converted to dots.
- A directory containing options files which may contain privileged options, even if pppd was invoked by a user other than root. The system administrator can create options files in this directory to permit non-privileged users to dial out without requiring the peer to authenticate, but only to certain trusted peers.
参见 SEE ALSO
- Jacobson, V. Compressing TCP/IP headers for low-speed serial links. February 1990.
- Rivest, R. The MD5 Message-Digest Algorithm. April 1992.
- McGregor, G. PPP Internet Protocol Control Protocol (IPCP). May 1992.
- Lloyd, B.; Simpson, W.A. PPP authentication protocols. October 1992.
- Simpson, W.A. The Point-to-Point Protocol (PPP). July 1994.
- Simpson, W.A. PPP in HDLC-like Framing. July 1994.
- Haskin, D. IP Version 6 over PPP December 1998.
- SIGINT, SIGTERM
- 这些信号使得pppd终止该连线（关闭LCP），回存串列 串列设备的设定，并结束离开。
If the persist or demand option has been specified, pppd will try to reopen the serial device and start another connection (after the holdoff period). Otherwise pppd will exit. If this signal is received during the holdoff period, it causes pppd to end the holdoff period immediately.
- This signal toggles the state of the debug option.
- This signal causes pppd to renegotiate compression. This can be useful to re-enable compression after it has been disabled as a result of a fatal decompression error. (Fatal decompression errors generally indicate a bug in one or other implementation.)
作者 AUTHOR S
Paul Mackerras (Paul.Mackerras@cs.anu.edu.au), based on earlier work by Drew Perkins, Brad Clements, Karl Fox, Greg Christy, and Brad Parker.
软件教程之Linux Man <email@example.com> <Best Linux> 1999
中文 man 手册页计划：https://github.com/man-pages-zh/manpages-zh